How to configure VXLAN Flood and Learn

Learn how to configure a simple VXLAN Flood and Learn topology

Alt text

Theory

VXLAN Flood and Learn is used to maintain a Layer 2 network over a Layer 3 network. The switches run a NVE interface also called VTEP that is used to encapsulate the original frame in a UDP packet and flood it along a multicast tree. The other switches that participate in the same multicast tree will decapsulate the packet and flood it out of their local ports based on the Vlan.


  • 1. SRV1 sends ARP to discover SRV2
  • 2. VTEP1 looksup the VLAN to VNI mapping and encapsalutes the ARP inside the VXLAN VNI header
  • 3. VTEP1 adds its NVE interface as Source IP and sends the packet to the multicast group of the VNID
  • 4. VTEP2 receives the multicast and decapsulates the packet and floods it to the mapped VLAN of the VXLAN VNID
  • 5. SRV2 gets the ARP and will send an ARP reply to SRV1
  • 6. VTEP2 looksup the VLAN to VNI mapping and encapsulate the arp reply inside the VXLAN VNI header
  • 7. VTEP2 use its NVE interface as Source IP and sends the packet to the IP of the NVE interface of VTEP1
  • 8. LEAF1 gets the ARP reply, decapsulates the VXLAN header and switches the ARP reply to SRV1

Configuration

VTEP1

feature pim
feature vn-segment-vlan-based
feature nv overlay 

ip route 10.10.10.2/32 10.1.1.2
ip pim rp-address 10.10.10.1 group-list 224.0.0.0/4

int lo10
  ip add 10.10.10.1/32
  ip pim sparse-mode 

int e1/1
 no switchport
 no sh
 ip add 10.1.1.1/30
 ip pim sparse-mode

int e1/2
 switchport access vlan 10

vlan 10
 vn-segment 1000

interface nve1
  no shutdown
  source-interface loopback10
  member vni 1000 mcast-group 230.1.1.1 

VTEP2

feature pim
feature vn-segment-vlan-based
feature nv overlay 

ip route 10.10.10.1/32 10.1.1.1
ip pim rp-address 10.10.10.1 group-list 224.0.0.0/4

int lo10
  ip address 10.10.10.2/32
  ip pim sparse-mode 

int e1/1
 no switchport
 no sh
 ip add 10.1.1.2/30
 ip pim sparse-mode

int e1/2
 switchport access vlan 10

vlan 10
 vn-segment 1000

interface nve1
  no shutdown
  source-interface loopback10
  member vni 1000 mcast-group 230.1.1.1 

Debug Commands

show nve interface
show nve peers
show nve vni
show ip mroute 230.1.1.1
show ip pim neighbor

Thanks for reading my article. If you have any questions or recommendations you can message me via arvednetblog@gmail.com.